VS:GetMtlPenForeColor

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the pen foreground color of the specified material. The color is returned as the RGB components of the color. RGB values are in the range of 0~65535.

PROCEDURE GetMtlPenForeColor(
material :HANDLE;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetMtlPenForeColor(material):
    return (red, green, blue)

Parameters

material HANDLE Handle to material.
red LONGINT Returns RGB color component (red).
green LONGINT Returns RGB color component (green).
blue LONGINT Returns RGB color component (blue).

Remarks

Returns the pen foreground color setting of the material in parameters colorRV, colorGV, and colorBV.

Example

GetMtlPenForeColor(mtlHandle,cRed,cGrn,cBlu);
RGBToColorIndex(cRed,cGrn,cBlu,colorValue);

Version

Availability: from Vectorworks 2021