VS:GetMtlPenBackColor: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:48, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the pen background color of the specified material. The color is returned as the RGB components of the color. RGB values are in the range of 0~65535.

PROCEDURE GetMtlPenBackColor(
material :HANDLE;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetMtlPenBackColor(material):
    return (red, green, blue)

Parameters

material HANDLE Handle to material.
red LONGINT Returns RGB color component (red).
green LONGINT Returns RGB color component (green).
blue LONGINT Returns RGB color component (blue).

Remarks

Returns the pen background color of the material in parameters colorRV, colorGV, and colorBV.

Example

GetMtlPenBackColor(mtlHandle,cRed,cGrn,cBlu);
RGBToColorIndex(cRed,cGrn,cBlu,colorValue);

Version

Availability: from Vectorworks 2021