VS:GetMtlFillForeColor

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the fill foreground color of the specified material. The color is returned as the RGB components of the color. RGB values are in the range of 0~65535.

PROCEDURE GetMtlFillForeColor(
material :HANDLE;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetMtlFillForeColor(material):
    return (red, green, blue)

Parameters

material HANDLE Handle to material.
red LONGINT Returns RGB color component (red).
green LONGINT Returns RGB color component (green).
blue LONGINT Returns RGB color component (blue).

Remarks

Returns the fill foreground color of the material in parameters colorRV, colorGV, and colorBV.

Example

GetMtlFillForeColor(mtlHandle,cRed,cGrn,cBlu);
RGBToColorIndex(cRed,cGrn,cBlu,colorValue);

Version

Availability: from Vectorworks 2021