VS:GetMarkerPopupSelectedItem/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

選択されているマーカスタイルを番号(1から始まる)で返します。カスタムが選択されている場合は8を返します。

FUNCTION GetMarkerPopupSelectedItem(
dialogID :LONGINT;
componentID :LONGINT;
VAR style :INTEGER;
VAR angle :INTEGER;
VAR size :INTEGER) : INTEGER;
def vs.GetMarkerPopupSelectedItem(dialogID, componentID):
    return (INTEGER, style, angle, size)

Parameters

dialogID LONGINT ダイアログ番号
componentID LONGINT マーカポップアップ番号
style INTEGER スタイル(1:塗りつぶし矢印/2:閉矢印/3:開矢印/4:黒丸/5:空白丸/6:斜線/7:十字線)
angle INTEGER 角度
size INTEGER 長さ

Version

利用可能バージョン: VectorWorks10.5