VS:GetMarkerPopupSelectedItem: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This is a deprecated function. Use GetMarkerChoice instead.

Returns the 1-based index number of the selected item in the specified marker popup menu item. If return value is 8, a custom marker is selected.

FUNCTION GetMarkerPopupSelectedItem(
dialogID :LONGINT;
componentID :LONGINT;
VAR style :INTEGER;
VAR angle :INTEGER;
VAR size :INTEGER) : INTEGER;
def vs.GetMarkerPopupSelectedItem(dialogID, componentID):
    return (INTEGER, style, angle, size)

Parameters

dialogID LONGINT ID of the dialog
componentID LONGINT ID of the marker popup item
style INTEGER On return, indicates the style of the selected marker. Valid styles:
angle INTEGER On return, indicates the angle of the selected marker, for arrow markers
size INTEGER On return, indicates the size of the selected marker

Version

Availability: from VectorWorks10.5