VS:GetMarkerChoice/ja

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

選択されているマーカスタイルを返します。


VW2008で使用できなくなった関数/手続きです。
GetMarkerValueをご利用ください。

PROCEDURE GetMarkerChoice(
dialogID :LONGINT;
itemID :LONGINT;
VAR index :INTEGER;
VAR style :INTEGER;
VAR angle :INTEGER;
VAR size :REAL);
def vs.GetMarkerChoice(dialogID, itemID):
    return (index, style, angle, size)

Parameters

dialogID LONGINT ダイアログ番号
itemID LONGINT アイテム番号
index INTEGER マーカ番号
style INTEGER スタイル
angle INTEGER 角度(度数)
size REAL 長さ(インチ)

Example

PROCEDURE Example;
VAR
   int, dialogID   :INTEGER;
   index, style, angle :INTEGER;
   size :REAL;

PROCEDURE Dialog_Handler(VAR item :LONGINT; data :LONGINT);
BEGIN
   CASE item OF
      SetupDialogC:
         BEGIN
            index := 1;
            style := 2;
            angle := 3;
            size  := .125;
            SetMarkerChoice(dialogID, 4, index, style, angle, size);
         END;
      5: 
         BEGIN
            GetMarkerChoice(dialogID, 4, index, style, angle, size);
            AlrtDialog(Concat(
	            'index: ', index, Chr(13), 
	            'style: ', style, Chr(13), 
	            'angle: ', angle, Chr(13), 
	            'size: ', size));
         END;
   END;
END;

BEGIN
   dialogID := CreateLayout('Test', False, 'OK', '');
   CreateMarkerPopup(dialogID, 4);
   CreatePushButton(dialogID, 5, '  Display Values  ');
   SetFirstLayoutItem(dialogID, 4);
   SetBelowItem(dialogID, 4, 5, 0, 2);
   int := RunLayoutDialog(dialogID, Dialog_Handler);
END;
RUN(Example);

Version

GetMarkerChoice 廃止バージョン: VectorWorks 2008


利用可能バージョン: VectorWorks12.0

See Also

関連関数:

VS:SetMarkerChoice

関連関数: [[VS:SetMarkerChoice]]