VS:GetLocalizedPluginChoice/ja

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

プラグイン、パラメータの名前、メニュー項目番号からローカライズ後の名前を返します。

プラグイン、パラメータの名前にはユニバーサルな名前を入れます。

FUNCTION GetLocalizedPluginChoice(
inPluginName :STRING;
inParameterName :STRING;
inChoiceIndex :INTEGER;
VAR outChoice :STRING) : BOOLEAN;
def vs.GetLocalizedPluginChoice(inPluginName, inParameterName, inChoiceIndex):
    return (BOOLEAN, outChoice)

Parameters

inPluginName STRING プラグインの名前
inParameterName STRING パラメータの名前
inChoiceIndex INTEGER メニュー項目番号(1からnの範囲)
outChoice STRING ローカライズ後の名前

Return Value

TRUE:関数が正しく動作しました。

FALSE:関数が正しく動作しませんでした。

Version

利用可能バージョン: VectorWorks10.0

See Also

関連関数:

VS:GetLocalizedPluginName

関連関数: [[VS:GetLocalizedPluginName]]