VS:GetLineTypeChoice

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get current choice of line style popup dialog control. Choice is the internal index (reference number) of the line type.

PROCEDURE GetLineTypeChoice(
dialogID :LONGINT;
itemID :LONGINT;
VAR lineType :LONGINT);
def vs.GetLineTypeChoice(dialogID, itemID):
    return lineType

Parameters

dialogID LONGINT The index of the dialog layout containing the control.
itemID LONGINT The index of the line style control.
lineType LONGINT The internal index (reference number) of the line type.

Version

Availability: from Vectorworks 2015