VS:GetLineTypeAttriData

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the current choices for the combined line style and line weight dialog control. The line type value is the line type internal index (reference number). The line weight value is in mils.

PROCEDURE GetLineTypeAttriData(
dialogID :LONGINT;
itemID :LONGINT;
VAR lineType :LONGINT;
VAR lineWeight :INTEGER);
def vs.GetLineTypeAttriData(dialogID, itemID):
    return (lineType, lineWeight)

Parameters

dialogID LONGINT The index of the dialog layout containing the control.
itemID LONGINT The index of the line attribute control.
lineType LONGINT The internal index (reference number) of the line type.
lineWeight INTEGER The line weight.The value is in mils.

Version

Availability: from Vectorworks 2015