VS:GetLineTypeAtIndex

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the line type at the specified index in the line style control.

PROCEDURE GetLineTypeAtIndex(
dialogID :LONGINT;
itemID :LONGINT;
index :INTEGER;
VAR lineType :LONGINT);
def vs.GetLineTypeAtIndex(dialogID, itemID, index):
    return lineType

Parameters

dialogID LONGINT The index of the dialog layout containing the control.
itemID LONGINT The index of the line style control.
index INTEGER The choice index.
lineType LONGINT The internal index (reference number) of the line type.

Version

Availability: from Vectorworks 2015