VS:GetLineStyleChoice: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(add remark)
m (Transfer Orso to _c_)
 
Line 44: Line 44:
Get current choice of line style popup dialog control.  Choice is an index into list of linestyles available in current document.
Get current choice of line style popup dialog control.  Choice is an index into list of linestyles available in current document.


(Orso 2016.02.29): Returns a dash list index (not usable with VS:Index2Name).
[[User:CBM-c-|_c_]] (2016.02.29): Returns a dash list index (not usable with VS:Index2Name).
</remark>
</remark>



Latest revision as of 06:54, 30 December 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get current choice of line style popup dialog control. Choice is an index into list of linestyles available in current document.

PROCEDURE GetLineStyleChoice(
dialogID :LONGINT;
itemID :LONGINT;
VAR lineStyle :INTEGER);
def vs.GetLineStyleChoice(dialogID, itemID):
    return lineStyle

Parameters

dialogID LONGINT
itemID LONGINT
lineStyle INTEGER

Remarks

Get current choice of line style popup dialog control. Choice is an index into list of linestyles available in current document.

_c_ (2016.02.29): Returns a dash list index (not usable with VS:Index2Name).

Version

Availability: from VectorWorks 12.0