VS:GetLightInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetLightInfo returns the attributes of the referenced light object.

Table - Light Types
Light Type Constant
Directional 0
Point 1
Spot 2
PROCEDURE GetLightInfo(
h :HANDLE;
VAR lightType :INTEGER;
VAR brightness :INTEGER;
VAR isOn :BOOLEAN;
VAR castShadow :BOOLEAN);
def vs.GetLightInfo(h):
    return (lightType, brightness, isOn, castShadow)

Parameters

h HANDLE Handle to light.
lightType INTEGER Returns light type.
brightness INTEGER Returns light brightness.
isOn BOOLEAN Returns on-off status of light.
castShadow BOOLEAN Returns whether light casts shadows.

Version

Availability: from MiniCAD 7.0