VS:GetLightFalloff

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetLightFalloff returns the fall off attributes for the referenced light object.

Table - Light Falloff Types
Falloff Type Constant
None 0
Normal 1
Smooth 2
Sharp 3
PROCEDURE GetLightFalloff(
light :HANDLE;
VAR distFalloff :INTEGER;
VAR angFalloff :INTEGER);
def vs.GetLightFalloff(light):
    return (distFalloff, angFalloff)

Parameters

light HANDLE Handle to light.
distFalloff INTEGER Returns distance falloff value.
angFalloff INTEGER Returns angular falloff value.

Remarks

Returns the falloff functions for the light. 0 = None, 1 = Normal, 2 = Smooth, 3 = Sharp (angular falloff only).

Version

Availability: from MiniCAD7.0.1