VS:GetLightFalloff

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetLightFalloff returns the fall off attributes for the referenced light object.

Table - Light Falloff Types
Falloff Type Constant
None 0
Normal 1
Smooth 2
Sharp 3
PROCEDURE GetLightFalloff(
light :HANDLE;
VAR distFalloff :INTEGER;
VAR angFalloff :INTEGER);
def vs.GetLightFalloff(light):
    return (distFalloff, angFalloff)

Parameters

light HANDLE Handle to light.
distFalloff INTEGER Returns distance falloff value.
angFalloff INTEGER Returns angular falloff value.

Remarks

Returns the falloff functions for the light. 0 = None, 1 = Normal, 2 = Smooth, 3 = Sharp (angular falloff only).

Version

Availability: from MiniCAD7.0.1