VS:GetLightColorRGB

From Vectorworks Developer
Revision as of 22:16, 27 April 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetLightColorRGB returns the RGB color values for the referenced light object.

PROCEDURE GetLightColorRGB(
light :HANDLE;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetLightColorRGB(light):
    return (red, green, blue)

Parameters

light HANDLE Handle to light.
red LONGINT Returns RGB color component value.
green LONGINT Returns RGB color component value.
blue LONGINT Returns RGB color component value.

Remarks

Color param range is 0..65535 -DLD 8/28/98

Version

Availability: from MiniCAD7.0.1