VS:GetLevelTypeName

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the name of the nth Level Type in the file. For example, if 3 is passed in, it will return the name of the 3rd Level Type in the file.

FUNCTION GetLevelTypeName(
index :INTEGER) : STRING;
def vs.GetLevelTypeName(index):
    return STRING

Parameters

index INTEGER The index of the level type whose name is desired.

Return Value

The name of the indicated level type.

Example

VAR

levelTypeName:STRING;

BEGIN

levelTypeName:=GetLayerLevelTypeName(2);

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:GetNumLayerLevelTypes | VS:SetLevelTypeName

VS Functions:

[[VS:GetNumLayerLevelTypes]]

| [[VS:SetLevelTypeName]]