VS:GetLevelTemplateInfo

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Root (talk | contribs) (1 revision: vw2015)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Used to access the properties of the Story Level Template at 'index'. The name, scaleFactor, levelType, elevation, and wallHeight parameters of the requested Story Level Template will be returned in the appropriate parameters.

FUNCTION GetLevelTemplateInfo(
index :INTEGER;
VAR layerName :STRING;
VAR scaleFactor :REAL;
VAR levelType :STRING;
VAR elevation :REAL;
VAR wallHeight :REAL) : BOOLEAN;
def vs.GetLevelTemplateInfo(index):
    return (BOOLEAN, layerName, scaleFactor, levelType, elevation, wallHeight)

Parameters

index INTEGER The index of the desired Story Level Template.
layerName STRING The layer name associated with the Story Level Template at 'index'. If this is empty, the corresponding Story Level Template does not use or create a layer.
scaleFactor REAL The scale of the layer associated with the Story Level Template at 'index'. If this layer name is blank, this parameter has no use.
levelType STRING The level type of the Story Level Template at 'index'.
elevation REAL The elevation of the Story Level Template at 'index'.
wallHeight REAL The wall height of the Story Level Template at 'index'. If the layer name is blank, this parameter has no meaning.

Return Value

Whether the Story Level Template at 'index' was found and valid.

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:GetNumLevelTemplates | VS:GetLevelTemplateName | VS:SetLevelTemplateName | VS:CreateLevelTemplate | VS:DeleteLevelTemplate | VS:GetLevelTemplateInfo

VS Functions:

[[VS:GetNumLevelTemplates]] | [[VS:GetLevelTemplateName]] | [[VS:SetLevelTemplateName]] | [[VS:CreateLevelTemplate]] | [[VS:DeleteLevelTemplate]]

| [[VS:GetLevelTemplateInfo]]