VS:GetLayoutDialogPosition

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function will retrieve the screen location of the dialog window, in pixels.

This function can be useful for displaying a dialog in a position in which it was placed during prior use.

FUNCTION GetLayoutDialogPosition(
dialogID :LONGINT;
VAR left :INTEGER;
VAR top :INTEGER;
VAR right :INTEGER;
VAR bottom :INTEGER) : BOOLEAN;
def vs.GetLayoutDialogPosition(dialogID):
    return (BOOLEAN, left, top, right, bottom)

Parameters

dialogID LONGINT Index of the dialog.
left INTEGER Location of left edge of dialog, in pixels.
top INTEGER Location of top of dialog, in pixels.
right INTEGER Location of right edge of dialog, in pixels.
bottom INTEGER Location of bottom edge of dialog, in pixels.

Return Value

true - success - the location of the dialog window was retrieved.

false - failure - the location of the dialog window was not retrieved, likely because it does not currently exist, or the dialogID is invalid. The dialog window will exist anytime between the Setup message and OK/Cancel message.

Version

Availability: from VectorWorks11.0

See Also

VS Functions:

VS:SetLayoutDialogPosition

VS Functions: [[VS:SetLayoutDialogPosition]]