VS:GetLayerForStory

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the layer with the story and layer level type specified.

FUNCTION GetLayerForStory(
story :HANDLE;
levelType :STRING) : HANDLE;
def vs.GetLayerForStory(story, levelType):
    return HANDLE

Parameters

story HANDLE The Story for which the will be looked up for level types.
levelType STRING The level type of the story, which associated layer will be returned.

Return Value

The Layer associated with the Story and layer level specified, which may be NULL.

Example

VAR

layer:HANDLE;

BEGIN

layer:=GetLayerForStory(story);

Version

Availability: from Vectorworks 2012

See Also

VS Functions:

VS:GetStoryOfLayer | VS:GetNumStories | VS:CreateStory | VS:AssociateLayerWithStory

VS Functions:

[[VS:GetStoryOfLayer]] | [[VS:GetNumStories]] | [[VS:CreateStory]]

| [[VS:AssociateLayerWithStory]]