VS:GetLayerElevation: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the elevation and thickness of the specified layer.

PROCEDURE GetLayerElevation(
h :HANDLE;
VAR baseElev :REAL;
VAR thickness :REAL);
def vs.GetLayerElevation(h):
    return (baseElev, thickness)

Parameters

h HANDLE Handle to the layer
baseElev REAL Base elevation of the layer
thickness REAL Thickness of the layer

Remarks

orso 2006.11.25: Please note that this routines always returns millimeters.

Example

VectorScript

PROCEDURE Example;
VAR
    h :HANDLE; 
    baseElev, thickness :REAL;
BEGIN
    h := FLayer;
    WHILE h <> NIL DO BEGIN
        GetLayerElevation(h, baseElev, thickness);
        thickness := thickness / (25.4 / GetPrefReal(152)); { convert from mm to current units }
        AlrtDialog(Concat('layer name: ', GetLName(h), ', baseElev: ', baseElev, ', thickness: ', thickness));
        h := NextLayer(h);
    END;
END;
RUN(Example);

Python

def Example():
    h = vs.FLayer()
    while h != None:
        baseElev, thickness = vs.GetLayerElevation(h)
        thickness = thickness / (25.4 / vs.GetPrefReal(152)) #{ convert from mm to current units }
        vs.AlrtDialog(vs.Concat('layer name: ', vs.GetLName(h), ', baseElev: ', baseElev, ', thickness: ', thickness))
        h = vs.NextLayer(h)
Example()

Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:SetLayerElevation

VS Functions: [[VS:SetLayerElevation]]