VS:GetLayerAmbientInfo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetLayerAmbientInfo returns the attribute values for the ambient light object of the referenced layer.

PROCEDURE GetLayerAmbientInfo(
layer :HANDLE;
VAR isOn :BOOLEAN;
VAR brightness :INTEGER);
def vs.GetLayerAmbientInfo(layer):
    return (isOn, brightness)

Parameters

layer HANDLE Handle to layer.
isOn BOOLEAN On-off status of ambient light.
brightness INTEGER Brightness of ambient light.

Remarks

brightness is a percentage value

Version

Availability: from VectorWorks8.0