VS:GetLayerAmbientColor

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Procedure GetLayerAmbientColor returns the color of the ambient light of the referenced layer. RGB values are in the range of 0~65535.

PROCEDURE GetLayerAmbientColor(
layer :HANDLE;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetLayerAmbientColor(layer):
    return (red, green, blue)

Parameters

layer HANDLE Handle to layer.
red LONGINT Returns RGB color component value.
green LONGINT Returns RGB color component value.
blue LONGINT Returns RGB color component value.

Version

Availability: from VectorWorks8.0