VS:GetLScale

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetLScale returns the scale of the referenced layer.

FUNCTION GetLScale(
h :HANDLE) : REAL;
def vs.GetLScale(h):
    return REAL

Parameters

h HANDLE Handle to layer.

Remarks

Joel Sciamma 2006.02.20: Returns 200 for 1:200, 1 for 1:1 and 0.5 for 2x

Example

VectorScript

LayerScale := GetLScale(LayerHandle);

Python

LayerScale  = vs.GetLScale(vs.ActLayer())

Version

Availability: from All Versions