VS:GetLScale

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetLScale returns the scale of the referenced layer.

FUNCTION GetLScale(
h :HANDLE) : REAL;
def vs.GetLScale(h):
    return REAL

Parameters

h HANDLE Handle to layer.

Remarks

Joel Sciamma 2006.02.20: Returns 200 for 1:200, 1 for 1:1 and 0.5 for 2x

Example

VectorScript

LayerScale := GetLScale(LayerHandle);

Python

LayerScale  = vs.GetLScale(vs.ActLayer())

Version

Availability: from All Versions