VS:GetLSN: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
(add example and remark)
Line 31: Line 31:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>
([[User:Orso.b.schmid|Orso]] 2016.02.29): Expects a name list index, while the older routine [[VS:GetLS]] expected a dash style index.
 
<code lang="vs">
styleName := Index2Name(-GetLSN(FSActLayer));
{ returns the name of the dash style defintion of the first selected object }
</code>
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 16:39, 1 March 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetLSN returns the line style of the referenced object.

FUNCTION GetLSN(
h :HANDLE) : LONGINT;
def vs.GetLSN(h):
    return LONGINT

Parameters

h HANDLE Handle to object.

Remarks

(Orso 2016.02.29): Expects a name list index, while the older routine VS:GetLS expected a dash style index.

styleName := Index2Name(-GetLSN(FSActLayer));
{ returns the name of the dash style defintion of the first selected object }

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:SetLSN

VS Functions: [[VS:SetLSN]]