VS:GetLS: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(add remark)
Line 30: Line 30:
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<remark>
([[User:Orso.b.schmid|Orso]] 2016.02.29): This is deprecated and returns always -1 as of VW 2016.
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
Line 35: Line 40:
==== VectorScript ====
==== VectorScript ====
<code lang="pas">
<code lang="pas">
lStyleValue:=GetLS(handleToObject);
lStyleValue := GetLS(handleToObject);
</code>
</code>
==== Python ====
==== Python ====
Line 48: Line 53:


</version>
</version>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>

Revision as of 17:04, 1 March 2016

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Use GetLSN instead.

Function GetLS returns the line style of the referenced object.

FUNCTION GetLS(
h :HANDLE) : INTEGER;
def vs.GetLS(h):
    return INTEGER

Parameters

h HANDLE Handle to object.

Remarks

(Orso 2016.02.29): This is deprecated and returns always -1 as of VW 2016.

Example

VectorScript

lStyleValue := GetLS(handleToObject);

Python

lStyleValue = vs.GetLS(handleToObject)

Version

Availability: from All Versions, deprecated from Vectorworks 2013

See Also

GetLSN from Vectorworks 2013

[[VS:GetLSN|GetLSN]] from Vectorworks 2013