VS:GetLBOrigNameClLevel

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

This function returns the close levels for an original name in the list browser. If the item for the name is displayed, then all the closeLevels will be false.

PROCEDURE GetLBOrigNameClLevel(
dialogID :LONGINT;
componentID :LONGINT;
originalName :STRING;
VAR level1Closed :BOOLEAN;
VAR level2Closed :BOOLEAN;
VAR level3Closed :BOOLEAN);
def vs.GetLBOrigNameClLevel(dialogID, componentID, originalName):
    return (level1Closed, level2Closed, level3Closed)

Parameters

dialogID LONGINT The id of the dialog.
componentID LONGINT The id of the list browser.
originalName STRING The original name of the item.
level1Closed BOOLEAN Whether the item's level 1 container is closed.
level2Closed BOOLEAN Whether the item's level 2 container is closed.
level3Closed BOOLEAN Whether the item's level 3 container is closed.

Version

Availability: from Vectorworks 2013