VS:GetLBMultImageIndexes

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the index of the images within the list browser multi image display.

FUNCTION GetLBMultImageIndexes(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
VAR imageIndex0 :INTEGER;
VAR imageIndex1 :INTEGER;
VAR imageIndex2 :INTEGER) : BOOLEAN;
def vs.GetLBMultImageIndexes(dialogID, componentID, itemIndex, subItemIndex):
    return (BOOLEAN, imageIndex0, imageIndex1, imageIndex2)

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
imageIndex0 INTEGER the 'ics8' resource index of the first image
imageIndex1 INTEGER the 'ics8' resource index of the second image
imageIndex2 INTEGER the 'ics8' resource index of the third image

Version

Availability: from VectorWorks12.0