VS:GetLBItemPatternIndex

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the specified list browser item's pattern index.

FUNCTION GetLBItemPatternIndex(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
the column index :INTEGER;
VAR outPatIndex :INTEGER) : BOOLEAN;
def vs.GetLBItemPatternIndex(dialogID, componentID, itemIndex, the column index):
    return (BOOLEAN, outPatIndex)

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
the column index INTEGER the column index
outPatIndex INTEGER Output parameter. Returns the pattern index of this item. Value from [1..71] see VS:Function Reference Appendix#Fill Patterns

Version

Availability: from Vectorworks 2010

See Also

VS:SetLBItemPatternIndex

[[VS:SetLBItemPatternIndex]]