VS:GetLBItemOrigName

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the original name for a list browser item when hierarchical display is on. If the item is a container item, it will return an empty string.

FUNCTION GetLBItemOrigName(
dialogID :LONGINT;
compenentID :LONGINT;
itemIndex :INTEGER) : STRING;
def vs.GetLBItemOrigName(dialogID, compenentID, itemIndex):
    return STRING

Parameters

dialogID LONGINT The id of the dialog.
compenentID LONGINT The id of the list browser.
itemIndex INTEGER The index of the item for which the original name is returned.

Return Value

The original name of the indicated item.

Version

Availability: from Vectorworks 2013

See Also

VS Functions:

VS:AddLBOriginalName

VS Functions: [[VS:AddLBOriginalName]]