VS:GetLBItemLineType

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Root (talk | contribs) (1 revision: vw2015)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the specified list browser item's line type.

FUNCTION GetLBItemLineType(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
VAR lineType :LONGINT;
VAR lineWeight :INTEGER) : BOOLEAN;
def vs.GetLBItemLineType(dialogID, componentID, itemIndex, subItemIndex):
    return (BOOLEAN, lineType, lineWeight)

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
lineType LONGINT the line type internal index (reference number)
lineWeight INTEGER the line weight

Version

Availability: from Vectorworks 2015