VS:GetLBItemInfo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets string and image information for a specified item of a List Browser control.

FUNCTION GetLBItemInfo(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
VAR itemString :STRING;
VAR imageIndex :INTEGER) : BOOLEAN;
def vs.GetLBItemInfo(dialogID, componentID, itemIndex, subItemIndex):
    return (BOOLEAN, itemString, imageIndex)

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the item index
subItemIndex INTEGER the subitem index
itemString STRING the item text
imageIndex INTEGER the item image list index

Remarks

<li>itemIndex = row

<li>subItemIndex = column

Version

Availability: from VectorWorks11.0