VS:GetLBItemFillForeColor

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the specified list browser item's fill foreground color.

FUNCTION GetLBItemFillForeColor(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
VAR redIndex :INTEGER;
VAR greenIndex :INTEGER;
VAR blueIndex :INTEGER) : BOOLEAN;
def vs.GetLBItemFillForeColor(dialogID, componentID, itemIndex, subItemIndex):
    return (BOOLEAN, redIndex, greenIndex, blueIndex)

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
redIndex INTEGER the red component (0 - 255)
greenIndex INTEGER the green component (0 - 255)
blueIndex INTEGER the blue component (0 - 255)

Version

Availability: from VectorWorks12.0