VS:GetLBEventInfo

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the last event information for the specified list browser.

FUNCTION GetLBEventInfo(
dialogID :LONGINT;
componentID :LONGINT;
VAR eventType :INTEGER;
VAR rowIndex :INTEGER;
VAR columIndex :INTEGER) : BOOLEAN;
def vs.GetLBEventInfo(dialogID, componentID):
    return (BOOLEAN, eventType, rowIndex, columIndex)

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
eventType INTEGER
rowIndex INTEGER the row index where the click occurred.
columIndex INTEGER the column index where the click occurred.

Remarks

eventType

kMessageDataChangeClick = -2;
kMessageDataChangeAllClick = -3;
kMessageSelectionChangeClick = -4;
kMessageDoubleClick = -5;
kMessageDeleteKeyPressed = -6;
kMessageUpKeyPressed = -7;
kMessageDownKeyPressed = -8;
kMessageAlphaNumericKeyPressed = -9;
kMessageSortOccurred = -10;
kMessageEnterKeyPressed = -12;
kMessageDataChangeRecursiveClick = -13;
kMessageDoubleAllClick = -14;
kMessageDoubleRecursiveClick = -15;

Version

Availability: from VectorWorks12.0