VS:GetLBColumnOwnerDrawnType

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the list browser column's owner drawn type.

FUNCTION GetLBColumnOwnerDrawnType(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER;
subItemIndex :INTEGER;
VAR ownerDrawnType :INTEGER) : BOOLEAN;
def vs.GetLBColumnOwnerDrawnType(dialogID, componentID, itemIndex, subItemIndex):
    return (BOOLEAN, ownerDrawnType)

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
itemIndex INTEGER the row index
subItemIndex INTEGER the column index
ownerDrawnType INTEGER None - 0

Remarks

(Orso, 2011 Oct. 08): This routine is non functional (tested from VW12 up to VW16): while it doesn't fail, it always sets "ownerDrawnType" to "0".

Version

Availability: from VectorWorks 12.0