VS:GetLBColumnDataItemInfo

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the specified column data item's text, image and user data.

FUNCTION GetLBColumnDataItemInfo(
dialogID :LONGINT;
componentID :LONGINT;
columnIndex :INTEGER;
columnDataItemIndex :INTEGER;
VAR itemString :STRING;
VAR imageOn :INTEGER;
VAR imageOff :INTEGER;
VAR itemData :LONGINT) : BOOLEAN;
def vs.GetLBColumnDataItemInfo(dialogID, componentID, columnIndex, columnDataItemIndex):
    return (BOOLEAN, itemString, imageOn, imageOff, itemData)

Parameters

dialogID LONGINT id of the dialog that contains the list browser
componentID LONGINT id of the list browser control
columnIndex INTEGER the column from which to get the data
columnDataItemIndex INTEGER the column data item
itemString STRING the item text
imageOn INTEGER the 'on' image list index
imageOff INTEGER the 'off' image list index
itemData LONGINT the item user data

Version

Availability: from VectorWorks11.0