VS:GetImagePopupSelectedItem: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 14:32, 12 August 2013

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the selected image popup item.

FUNCTION GetImagePopupSelectedItem(
dialogID :LONGINT;
componentID :LONGINT) : INTEGER;
def vs.GetImagePopupSelectedItem(dialogID, componentID):
    return INTEGER

Parameters

dialogID LONGINT Index to the dialog layout that contains the image popup component.
componentID LONGINT Index to a specific image popup component.

Return Value

Returns the image popup index for the currently selected item.

Remarks

Returns the index to the Item that is currently selected in the image pop-up control. Currently there is always a selected item.

ComponentID is the dialog Item index of the control

This function is currently returning item indexes assuming a 1-based index whereas GetImagePopupObject() assumes a zero based index. This will hopefully be fixed for release so that all layout mgr dialog controls use a zero based indexing system for lists of items.

Example

VectorScript

selectedItemIndex := GetImagePopupSelectedItem(dialogID, componentID);

Python

selectedItemIndex = vs.GetImagePopupSelectedItem(dialogID, componentID)

Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:InsertImagePopupObjectItem | VS:GetNumImagePopupItems | VS:GetImagePopupObject | VS:GetImagePopupObjectItemIndex | VS:SetImagePopupSelectedItem | VS:RemoveImagePopupItem | VS:RemoveAllImagePopupItems

VS Functions:

[[VS:InsertImagePopupObjectItem]] | [[VS:GetNumImagePopupItems]] | [[VS:GetImagePopupObject]] | [[VS:GetImagePopupObjectItemIndex]] | [[VS:SetImagePopupSelectedItem]] | [[VS:RemoveImagePopupItem]]

| [[VS:RemoveAllImagePopupItems]]