VS:GetImagePopupObjectItemIndex

From Vectorworks Developer
Revision as of 08:58, 16 April 2018 by MaKro (talk | contribs)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Return item index for the specified object (or zero if not found).

FUNCTION GetImagePopupObjectItemIndex(
dialogID :LONGINT;
componentID :LONGINT;
objectName :STRING) : INTEGER;
def vs.GetImagePopupObjectItemIndex(dialogID: int, componentID: int, objectName: str):
    return int

Parameters

dialogID LONGINT Index to the dialog layout that contains the image popup component.
componentID LONGINT Index to a specific image popup component.
objectName STRING Name of object for which the image popup index should be retrieved.

Return Value

Returns the 1-based image popup index for the specified object or zero if objectName could not be found.

Example

VectorScript

imagePopupIndex := GetImagePopupObjectItemIndex(dialogID, componentID, 'Symbol-1');

Python

imagePopupIndex = vs.GetImagePopupObjectItemIndex(dialogID, componentID, 'Symbol-1')

Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:InsertImagePopupObjectItem | VS:GetNumImagePopupItems | VS:GetImagePopupObject | VS:SetImagePopupSelectedItem | VS:GetImagePopupSelectedItem | VS:RemoveImagePopupItem | VS:RemoveAllImagePopupItems

VS Functions:

[[VS:InsertImagePopupObjectItem]] | [[VS:GetNumImagePopupItems]] | [[VS:GetImagePopupObject]] | [[VS:SetImagePopupSelectedItem]] | [[VS:GetImagePopupSelectedItem]] | [[VS:RemoveImagePopupItem]]

| [[VS:RemoveAllImagePopupItems]]