VS:GetImagePopupObjectItemIndex: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
mNo edit summary
Line 41: Line 41:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
Returns the image popup index for the specified object.</return>
Returns the 0-based image popup index for the specified object.</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Revision as of 08:51, 16 April 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns item index for the specified object.

FUNCTION GetImagePopupObjectItemIndex(
dialogID :LONGINT;
componentID :LONGINT;
objectName :STRING) : INTEGER;
def vs.GetImagePopupObjectItemIndex(dialogID, componentID, objectName):
    return INTEGER

Parameters

dialogID LONGINT Index to the dialog layout that contains the image popup component.
componentID LONGINT Index to a specific image popup component.
objectName STRING Name of object for which the image popup index should be retrieved.

Return Value

Returns the 0-based image popup index for the specified object.

Example

VectorScript

imagePopupIndex := GetImagePopupObjectItemIndex(dialogID, componentID, 'Symbol-1');

Python

imagePopupIndex = vs.GetImagePopupObjectItemIndex(dialogID, componentID, 'Symbol-1')

Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:InsertImagePopupObjectItem | VS:GetNumImagePopupItems | VS:GetImagePopupObject | VS:SetImagePopupSelectedItem | VS:GetImagePopupSelectedItem | VS:RemoveImagePopupItem | VS:RemoveAllImagePopupItems

VS Functions:

[[VS:InsertImagePopupObjectItem]] | [[VS:GetNumImagePopupItems]] | [[VS:GetImagePopupObject]] | [[VS:SetImagePopupSelectedItem]] | [[VS:GetImagePopupSelectedItem]] | [[VS:RemoveImagePopupItem]]

| [[VS:RemoveAllImagePopupItems]]