VS:GetImagePopupObject

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the object name for the specified image popup item.

FUNCTION GetImagePopupObject(
dialogID :LONGINT;
componentID :LONGINT;
itemIndex :INTEGER) : STRING;
def vs.GetImagePopupObject(dialogID, componentID, itemIndex):
    return STRING

Parameters

dialogID LONGINT Index to the dialog layout that contains the image popup component.
componentID LONGINT Index to a specific image popup component.
itemIndex INTEGER Image popup item index for object to be retrieved.

Return Value

Returns name of object stored at specified image popup index.

Remarks

This procedure returns the name of the resource found in an image pop-up control at a specified index location in that pop-up.

-Component ID is the index to the dialog Item number for the control
-ItemIndex is the index to the item you wish to find the resource name
-ObjectName returns the resource name of the resource that is found in the image pop-up control at index itemIndex.
-This function will only return the name for resources in the current document. It will return an empty string if the resource is not in the document.

Example

VectorScript

objectName := GetImagePopupObject(dialogID, componentID, 4);

Python

objectName = vs.GetImagePopupObject(dialogID, componentID, 4)

Version

Availability: from VectorWorks10.0

See Also

VS Functions:

VS:InsertImagePopupObjectItem | VS:GetNumImagePopupItems | VS:GetImagePopupObjectItemIndex | VS:SetImagePopupSelectedItem | VS:GetImagePopupSelectedItem | VS:RemoveImagePopupItem | VS:RemoveAllImagePopupItems

VS Functions:

[[VS:InsertImagePopupObjectItem]] | [[VS:GetNumImagePopupItems]] | [[VS:GetImagePopupObjectItemIndex]] | [[VS:SetImagePopupSelectedItem]] | [[VS:GetImagePopupSelectedItem]] | [[VS:RemoveImagePopupItem]]

| [[VS:RemoveAllImagePopupItems]]