VS:GetIconPushButtonState

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the state of the specified Layout Manager icon push button (pressed or not pressed).

FUNCTION GetIconPushButtonState(
nDialogID :LONGINT;
nComponentID :LONGINT;
VAR bPressed :BOOLEAN) : BOOLEAN;
def vs.GetIconPushButtonState(nDialogID, nComponentID):
    return (BOOLEAN, bPressed)

Parameters

nDialogID LONGINT
nComponentID LONGINT
bPressed BOOLEAN

Remarks

Julian [2013/03/07]

As of Vw 2013 SP2 (177995), this call works differently on Mac and Windows due
to a bug. Here is an example of how it needs to be used on both platforms.
The example toggles the state of the icon push button:

MAC:
Flag := GetIconPushButtonState(DialogID, item, Flag2);
Flag := SetIconPushButtonState(DialogID, item, Flag2);

WIN:
Flag := GetIconPushButtonState(DialogID, item, Flag2);
Flag := SetIconPushButtonState(DialogID, item, NOT Flag2);

Version

Availability: from VectorWorks13.0