VS:GetGradientSpotColor

From Vectorworks Developer
Revision as of 14:32, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the spot color of the specified gradient segment.

PROCEDURE GetGradientSpotColor(
gradient :HANDLE;
segmentIndex :INTEGER;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT);
def vs.GetGradientSpotColor(gradient, segmentIndex):
    return (red, green, blue)

Parameters

gradient HANDLE Gradient that contains the segment.
segmentIndex INTEGER Segment from which to get the data.
red LONGINT Red component of the color spot's color.
green LONGINT Green component of the color spot's color.
blue LONGINT Blue component of the color spot's color.

Example

VectorScript

GetGradientSpotColor(gradientHandle, 4, red, green, blue);

Python

red, green, blue = vs.GetGradientSpotColor(gradientHandle, 4)

Version

Availability: from VectorWorks10.0