VS:GetGradientSlider

From Vectorworks Developer
Revision as of 14:35, 18 September 2014 by Root (talk | contribs) (1 revision: vw2015)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

PROCEDURE GetGradientSlider(
dialogID :LONGINT;
componentID :LONGINT;
segmentIndex :INTEGER;
VAR spotPosition :REAL;
VAR midpointPosition :REAL;
VAR red :LONGINT;
VAR green :LONGINT;
VAR blue :LONGINT;
VAR opacity :INTEGER);
def vs.GetGradientSlider(dialogID, componentID, segmentIndex):
    return (spotPosition, midpointPosition, red, green, blue, opacity)

Parameters

dialogID LONGINT Index to the dialog layout that contains the gradient slider component.
componentID LONGINT Index to a specific gradient slider component.
segmentIndex INTEGER Segment from which to get the data.
spotPosition REAL Position of the segment's color marker relative to left-most point of the slider.
midpointPosition REAL Position of the segment's midpoint marker relative to color marker immediately to left.
red LONGINT Red component of the color spot's color.
green LONGINT Red component of the color spot's color.
blue LONGINT Blue component of the color spot's color.
opacity INTEGER Opacity for the color at the spot position.

Example

GetGradientSlider(dialogID, componentID, 4, spotPosition, midpointPosition, red, green, blue,opacity);

Version

Availability: from Vectorworks 2015

See Also

VS Functions:

VS:SetGradientSlider | VS:InsertGradientSliSeg

VS Functions:

[[VS:SetGradientSlider]]

| [[VS:InsertGradientSliSeg]]