VS:GetGradientMidpointPosition

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the midpoint position of the specified gradient segment.

PROCEDURE GetGradientMidpointPosition(
gradient :HANDLE;
segmentIndex :INTEGER;
VAR position :REAL);
def vs.GetGradientMidpointPosition(gradient, segmentIndex):
    return position

Parameters

gradient HANDLE Gradient that contains the segment.
segmentIndex INTEGER Segment from which to get the data.
position REAL Position of the segment's midpoint relatvie to color spot immediately to left.

Example

VectorScript

GetGradientMidpointPosition(gradientHandle, 4, midpointPosition);

Python

midpointPosition = vs.GetGradientMidpointPosition(gradientHandle, 4)

Version

Availability: from VectorWorks10.0