VS:GetFontName

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Function GetFontName converts a system font ID to a font name.

An integer ID with a value representing a font in the current operating system.

FUNCTION GetFontName(
fontID :INTEGER) : STRING;
def vs.GetFontName(fontID):
    return STRING

Parameters

fontID INTEGER Font ID value.

Remarks

returns "" if the FontID is not legal.

Example

VectorScript

PROCEDURE Example;
VAR
str :STRING;
cnt :INTEGER;
BEGIN
FOR cnt := 0 to 10 DO str := Concat(str, Chr(13), GetFontName(cnt));
AlrtDialog(str);
END;
RUN(Example);

Python

def Example():
	str = ''
	for cnt in range(0,10):
		str = vs.Concat(str, vs.Chr(13), vs.GetFontName(cnt))
	vs.AlrtDialog(str)
Example()

Version

Availability: from VectorWorks8.0