VS:GetFolder

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Prompts for the selection of a folder. Defaults to the folder name in the argument list. Returns 0 if the user hits OK, and -1 if the user hits cancel.

FUNCTION GetFolder(
promptStr :STRING;
VAR directoryPath :STRING) :INTEGER;
def vs.GetFolder(promptStr):
    return (INTEGER, directoryPath)

Parameters

promptStr STRING
directoryPath STRING Output parameter.

Remarks

On the Mac, directoryPath will use foreslashes instead of colons.

Orso 2010.09.24: Foreslashes on Mac have been introduced by VW12. If you happen to script for older versions, be aware that this routines returned path with colons until VW11.

Example

PROCEDURE Example;
VAR
   promptStr :STRING; 
   directoryPath :STRING;
   result :INTEGER;
BEGIN
   promptStr := 'Select the folder...';
   directoryPath := GetFolderPath(2);
   result := GetFolder(promptStr, directoryPath);
   Message(directoryPath);
END;
Run(Example);

Version

Availability: from All Versions

This is drop-in function.