VS:GetFolder: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
(expand)
(4 intermediate revisions by the same user not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Prompts for the selection of a folder. Defaults to the folder name in the argument list. Returns 0 if the user hits OK, and -1 if the user hits cancel.
Gets the path to a user selected folder</desc>
</desc>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<def>
<def>
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION GetFolder(promptStr :STRING; VAR directoryPath :STRING) :INTEGER;
FUNCTION GetFolder(promptStr:STRING; VAR directoryPath:STRING) : INTEGER;
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
Line 30: Line 29:
directoryPath
directoryPath
STRING
STRING
Output parameter.
 
</line>
</line>
</lineList>
</lineList>
</params>
</params>
-----------------------------------------------------------------------------------------------------------
<return>
</return>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
On the Mac, directoryPath will use foreslashes instead of colons.
([[User:Orso.b.schmid|Orso]], 2014.03.25): This was hidden since VW 10 (NOT 2010!), so the compatibility is far more than VW 2014 only.


[[User:Orso.b.schmid| Orso]] 2010.09.24: Foreslashes on Mac have been introduced by VW12. If you happen to script for older versions, be aware that this routines returned path with colons until VW11.
Prompts for the selection of a folder. Defaults to the folder name in the argument list. Returns 0 if the user hits OK, and -1 if the user hits cancel. The starting VAR directoryPath is overwritten with the path of the chosen folder
</remark>
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
<code lang="pas">
See [[Python Sample Import Images as Symbols]] for example.
PROCEDURE Example;
 
<code lang="pas">PROCEDURE Example;
VAR
VAR
  promptStr :STRING;  
   promptStr :STRING;  
  directoryPath :STRING;
   directoryPath :STRING;
  result :INTEGER;
   result :INTEGER;
BEGIN
BEGIN
  promptStr := 'Select the folder...';
   promptStr := 'Select the folder...';
  directoryPath := GetFolderPath(2);
   directoryPath := GetFolderPath(3);
  result := GetFolder(promptStr, directoryPath);
   result := GetFolder(promptStr, directoryPath);
  Message(directoryPath);
   Message(directoryPath);
END;
END;
Run(Example);</code>
Run(Example);</code>
</sample>


</sample>
-----------------------------------------------------------------------------------------------------------
<seeAlso></seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Availability: from All Versions
Availability: from Vectorworks 2014


This is drop-in function.
</version>
</version>
-----------------------------------------------------------------------------------------------------------
<seeAlso>
</seeAlso>


</vwDoc>
</vwDoc>

Revision as of 17:41, 20 September 2014

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the path to a user selected folder

FUNCTION GetFolder(
promptStr :STRING;
VAR directoryPath :STRING) : INTEGER;
def vs.GetFolder(promptStr):
    return (INTEGER, directoryPath)

Parameters

promptStr STRING
directoryPath STRING

Remarks

(Orso, 2014.03.25): This was hidden since VW 10 (NOT 2010!), so the compatibility is far more than VW 2014 only.

Prompts for the selection of a folder. Defaults to the folder name in the argument list. Returns 0 if the user hits OK, and -1 if the user hits cancel. The starting VAR directoryPath is overwritten with the path of the chosen folder

Example

See Python Sample Import Images as Symbols for example.

PROCEDURE Example;
VAR
   promptStr :STRING; 
   directoryPath :STRING;
   result :INTEGER;
BEGIN
   promptStr := 'Select the folder...';
   directoryPath := GetFolderPath(3);
   result := GetFolder(promptStr, directoryPath);
   Message(directoryPath);
END;
Run(Example);

Version

Availability: from Vectorworks 2014