VS:GetFillPoints

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets start and axis end points of the fill.

Note: only works with 2D objects that have a gradient or image fill.

PROCEDURE GetFillPoints(
objectHandle :HANDLE;
VAR xOriginPoint :REAL;
VAR yOriginPoint :REAL;
VAR xIAxisEndPoint :REAL;
VAR yIAxisEndPoint :REAL;
VAR xJAxisEndPoint :REAL;
VAR yJAxisEndPoint :REAL);
def vs.GetFillPoints(objectHandle):
    return (xOriginPoint, yOriginPoint, xIAxisEndPoint, yIAxisEndPoint, xJAxisEndPoint, yJAxisEndPoint)

Parameters

objectHandle HANDLE Handle to the object with fill.
xOriginPoint REAL X coordinate of origin point.
yOriginPoint REAL Y coordinate of origin point.
xIAxisEndPoint REAL X coordinate of I-axis point.
yIAxisEndPoint REAL Y coordinate of I-axis point.
xJAxisEndPoint REAL X coordinate of J-axis point.
yJAxisEndPoint REAL Y coordinate of J-axis point.

Example

VectorScript

GetFillPoints(objectHandle);

Python

xOrigin, yOrigin, xIAxis, yIAxis, xJAxis, yJAxis = vs.GetFillPoints(vs.FSActLayer())

Version

Availability: from VectorWorks10.0