VS:GetFillOriginPoint

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the origin point of the fill.

Note: only works with 2D objects that have a gradient or image fill.

PROCEDURE GetFillOriginPoint(
objectHandle :HANDLE;
VAR xOriginPoint :REAL;
VAR yOriginPoint :REAL);
def vs.GetFillOriginPoint(objectHandle):
    return (xOriginPoint, yOriginPoint)

Parameters

objectHandle HANDLE Handle to the object with fill.
xOriginPoint REAL X coordinate of origin point.
yOriginPoint REAL Y coordinate of origin point.

Example

VectorScript

GetFillOriginPoint(objectHandle, xOrigin, yOrigin);

Python

xIAxis, yIAxis = vs.GetFillOriginPoint(vs.FSActLayer())

Version

Availability: from VectorWorks10.0