VS:GetFillJAxisEndPoint

From Vectorworks Developer
Revision as of 14:30, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Gets the J-axis end point of the fill.

Note: only works with 2D objects that have a gradient or image fill.

PROCEDURE GetFillJAxisEndPoint(
objectHandle :HANDLE;
VAR xJAxisEndPoint :REAL;
VAR yJAxisEndPoint :REAL);
def vs.GetFillJAxisEndPoint(objectHandle):
    return (xJAxisEndPoint, yJAxisEndPoint)

Parameters

objectHandle HANDLE Handle to the object with fill.
xJAxisEndPoint REAL X coordinate of J-axis point.
yJAxisEndPoint REAL Y coordinate of J-axis point.

Example

VectorScript

GetFillJAxisEndPoint(objectHandle, xJAxis, yJAxis);

Python

xIAxis, yIAxis = vs.GetFillJAxisEndPoint(vs.FSActLayer())

Version

Availability: from VectorWorks10.0